关于优酷视频源链算法&发布在线解析API

分类: 开发 | 时间: 2017-02-08 | 评论: 3条评论

最近想看「この素晴らしい世界に祝福を」,发现居!然!是!优!酷!独!播!垃圾优酷!
算了算了,能看就行啦,不要求那么多嘛。

然而。。。。

1.png

尼玛???!以前是不给看1080P,现在直接不给看了??垃圾优酷!

嗯,作为技术(偷税)人员,当然是网站查找破解办法啦,
然而。。。

因为优酷最近API有次大变动,网上大部分开源的视频链接解析项目都无法使用..

无法抑制自己的怒火啊!玛德自己去弄一个,顺便造福人类!垃圾优酷!
翻阅垃圾优酷的各种JS,花了2天时间终于研究透了优酷视频链接的算法,
简直太复杂了啊,特别是ep计算算法,好烦啊。果然是垃圾优酷,只有垃圾程序员会写这么复杂这么乱

虽然过程艰辛,但最后还是成功了呢!
如果有空我会把过程与大家一起分享,现在先贴上做好的东西吧:

API : https://kvv.me/someProjects/Youku/

参数:
-wz   (优酷视频网址)
-qxd (一般取值0--4 代表480P--1080P) (选填)

一般使用直接访问 https://kvv.me/someProjects/Youku/?wz= + 视频网址 就行了,会自动解析最高清晰度,基本秒解哦。
里面还加入了视频播放器,直接点击链接就可以在线观看,亲测1080P电影在线观看不会卡哦。
如果某些视频播放出现错误请刷新网页。

结果:以后看垃圾优酷视频再也不用担心广告和垃圾画质啦

iOS 8邮件App 最新严重 Bug:密码可能随时泄露!

分类: 新闻 | 时间: 2015-06-13 | 评论: 暂无评论

前言

Apple 刚刚在 iOS 8.4 Beta 4 中修复了死亡代码的 Bug,现在又发现新 Bug。据消息指,iOS 8 最新曝光的漏洞是基于邮件,该漏洞原理很简单、简单说就是透过 CSS 等在邮件内容内设计出一个类似 iCloud 式的登录视窗,藉以窃取用户密码。而一旦密码失窃,个人隐私及财产安全将不保。(其实归根结底这并非邮件 App 所独有的问题)

- 阅读剩余部分 -

打死网易 支付宝的新型DOS攻击——LFA

分类: 文章 | 时间: 2015-05-31 | 评论: 1条评论

前言

5月11日晚上9时许,网易的大量用户发现访问网易新闻、云音乐等服务出现问题,相应的,有很多游戏用户报告说游戏掉线严重。一时间,有关“网易大楼着火”的谣传甚嚣。晚上9点42分的时候,“网易新闻客户端”新浪微博发文称:“骨干网络遭受攻击,正在抢修”。约6小时后,旗下服务才基本恢复正常。

继网易之后,5月27日下午5点左右,支付宝出现全国范围的系统瘫痪,支付宝回应称:“由于杭州市萧山区某地光纤被挖断,造成目前少部分用户无法使用支付宝,运营商蜀黍正在抢修”,2小时后,支付宝恢复正常。有网友发现,此次支付宝故障和之前网易情况类似。

2868553230.jpg

这几次攻击,相较于以往的DDoS攻击,官方描述比较特别:“骨干网络遭受攻击”。笔者敏锐地意识到这是最近学术界才提出的LFA攻击,攻击范例比较少。本文接下来将详细介绍LFA攻击的概念、现状和防治方法。不过,悲观地讲,现在还没有关于LFA特别好的解决方案。

- 阅读剩余部分 -

利用PHP漏洞轻松打死网站集群

分类: 文章 | 时间: 2015-05-23 | 评论: 暂无评论

利用的漏洞: PHP 远程 DoS 漏洞(PHP Multipart/form-data remote dos Vulnerability)

漏洞详情:
5 月 14 日,国内爆出 php 远程 DoS 漏洞,官方编号69364。利用该漏洞构造 poc 发起链接,很容易导致目标主机cpu 的占用率 100%,涉及 PHP 多个版本。
4 月 3 日,有人在 PHP 官网提交 PHP 远程 DoS 漏洞(PHP Multipart/form-data remote dos Vulnerability),代号 69364①。由于该漏洞涉及 PHP 的所有版本,故其影响面较大,一经发布迅速引发多方面关注。14 日,各种 PoC 已经在网络上流传。

此次漏洞具备如下特性:

  1. 一旦被利用成功,可以在迅速消耗被攻击主机的 CPU 资源,从而达到 DoS 的目的;
  2. PHP 在全球的部署量相当大,为攻击者提供了相当多可以攻击的目标;
  3. PHP 官方目前仅给出了 5.4 及 5.5 版本的补丁受此漏洞影响的软件及系统包括 PHP 的如下版本。

适用 PHP 版本:
PHP 5.6.9 以下版本
PHP 5.5.25 以下版本
PHP 5.4.41 以下版本
PHP 5.3 及所有以前的版本

PS:只适用于未修复该漏洞的站点

- 阅读剩余部分 -

WordPress曝存储型XSS漏洞,影响4.2及以下版本

分类: 新闻 | 时间: 2015-05-03 | 评论: 暂无评论

WordPress官方在4月21日发布了新的版本4.1.2,其中提到修复了一个严重的存储型XSS漏洞。不久之后便有人给出了漏洞的细节。而安全研究团队Klikki Oy发现在,新版本(<=4.2)的Wordpress中仍然可以利用该漏洞。

- 阅读剩余部分 -